Security Experts:

Drupal Patches Critical Vulnerabilities in Three Modules

Drupal this week released security updates for three modules to patch Highly Critical and Critical remote code execution (RCE) vulnerabilities in them.

RESTWS, a module that enables users to expose Drupal entities as RESTful Web Services is among the affected modules. Because RESTWS alters the default page callbacks for entities to provide additional functionality, a vulnerability is created that allows an attacker to run arbitrary PHP code by sending specially crafted requests, the security advisory reads.

According to Drupal, the security flaw can be exploited by anonymous users and there are no mitigating factors. RESTful Web Services 7.x-2.x versions prior to 7.x-2.6 and 7.x-1.x versions prior to 7.x-1.7 are vulnerable, and users are advised to update to the patched versions as soon as possible.

Another Highly Critical arbitrary PHP code execution flaw was resolved in the Coder module, a second advisory reveals. The module was meant to check code against coding standards and other best practices, and can also be used to fix coding standard violations and perform basic upgrades on modules.

However, because the module doesn't perform sufficient validation of user inputs in a script file with the PHP extension, a malicious unauthenticated user can make requests directly to this file to execute arbitrary PHP code. Furthermore, the vulnerability can be exploited even if the module is not enabled, Drupal’s security team has discovered.

Coder module 7.x-1.x versions prior to 7.x-1.3 and 7.x-2.x versions prior to 7.x-2.6 are vulnerable, but the Drupal core is not affected. Affected users are advised to update to the latest version of Coder module for Drupal, or to remove the module from all publicly available websites to ensure that they are no longer affected.

Another remote code execution vulnerability was patched in the Webform Multiple File Upload module, which was meant to help users upload multiple files on a Webform. Because of the RCE flaw, “form inputs will be unserialized and a specially crafted form input may trigger arbitrary code execution depending on the libraries available on a site,” Drupal’s security team notes in an advisory.

The issue is mitigated by the fact that the attacker needs the ability to submit a Webform with a Multiple File Input field and because a site needs to use code that can be leveraged for malicious purposes. The vulnerability affects Webform Multifile 7.x-1.x versions prior to 7.x-1.4 and can be resolved by installing the latest available update.

Earlier this week Adobe patched over 80 vulnerabilities in Flash, Reader, and Acrobat, Microsoft resolved over 40 security flaws in Internet Explorer, Edge, Office, and other products, affecting all Windows versions, and SAP patched 36 bugs in its products, including 24 Clickjacking vulnerabilities. Before that, persistent XSS flaws were resolved in three WordPress plugins.

Related: Drupal Security Updates Patch Two Vulnerabilities

Related: Old Drupal Flaw Still Used to Hack Websites

view counter