Security Experts:

Connect with us

Hi, what are you looking for?

SecurityWeekSecurityWeek

Vulnerabilities

Critical Vulnerability in Premium Gift Cards WordPress Plugin Exploited in Attacks

Defiant’s Wordfence team warns of a critical-severity vulnerability in the YITH WooCommerce Gift Cards premium WordPress plugin being exploited in attacks.

Defiant’s Wordfence team warns of a critical-severity vulnerability in the YITH WooCommerce Gift Cards premium WordPress plugin being exploited in attacks.

The YITH WooCommerce Gift Cards plugin allows online merchants to create gift cards that their customers can purchase for their friends to use on the ecommerce store. The premium plugin has more than 50,000 installations, its developer says.

Tracked as CVE-2022-45359 (CVSS score of 9.8), the exploited vulnerability was reported in November and a patch for it was made available soon after.

The issue is described as an arbitrary file upload, allowing attackers to upload executable files to the WordPress sites that use a vulnerable version of the plugin. No authentication is required for successful exploitation, Wordfence says.

According to the WordPress security firm, an attacker can exploit the vulnerability to place a backdoor on a vulnerable installation, gain remote code execution (RCE), and potentially take over the site.

“We were able to reverse engineer the exploit based on attack traffic and a copy of the vulnerable plugin and are providing information on its functionality as this vulnerability is already being exploited in the wild and a patch has been available for some time,” Wordfence warns.

The security defect was found in an import function running on the admin_init hook, which runs for all pages in the /wp-admin/ directory.

Because the impacted function lacks cross-site request forgery (CSRF) and capability checks, an unauthenticated attacker could trigger the flaw by sending special requests containing specific parameters and payloads.

“Since the function also does not perform any file type checks, any file type including executable PHP files can be uploaded,” Wordfence underlines.

Site admins can identify signs of an attack by checking their logs for POST requests to wp-admin/admin-post.php.

According to Wordfence, observed attacks came from hundreds of IP addresses, but only two IPs were responsible for the majority of exploitation attempts. Most of the attacks occurred one day after the vulnerability was publicly disclosed, but they continue.

“As this vulnerability is trivial to exploit and provides full access to a vulnerable website, we expect attacks to continue well into the future,” Wordfence concludes.

Site admins are advised to update to YITH WooCommerce Gift Cards premium version 3.20.0 or newer, which contain patches for this vulnerability.

Related: WordPress Sites Hacked via Zero-Day Vulnerability in WPGateway Plugin

Related: Vulnerability in BackupBuddy Plugin Exploited to Hack WordPress Sites

Related: Unpatched WPBakery WordPress Plugin Vulnerability Increasingly Targeted in Attacks

Written By

Ionut Arghire is an international correspondent for SecurityWeek.

Click to comment

Daily Briefing Newsletter

Subscribe to the SecurityWeek Email Briefing to stay informed on the latest threats, trends, and technology, along with insightful columns from industry experts.

Expert Insights

Related Content

Cloud Security

VMware vRealize Log Insight vulnerability allows an unauthenticated attacker to take full control of a target system.

IoT Security

Lexmark warns of a remote code execution (RCE) vulnerability impacting over 120 printer models, for which PoC code has been published.

Application Security

Drupal released updates that resolve four vulnerabilities in Drupal core and three plugins.

Mobile & Wireless

Apple rolled out iOS 16.3 and macOS Ventura 13.2 to cover serious security vulnerabilities.

Email Security

Microsoft is urging customers to install the latest Exchange Server updates and harden their environments to prevent malicious attacks.

Vulnerabilities

Less than a week after announcing that it would suspended service indefinitely due to a conflict with an (at the time) unnamed security researcher...

Mobile & Wireless

Technical details published for an Arm Mali GPU flaw leading to arbitrary kernel code execution and root on Pixel 6.

Vulnerabilities

A high-severity format string vulnerability in F5 BIG-IP can be exploited to cause a DoS condition and potentially execute arbitrary code.