Security Experts:

Connect with us

Hi, what are you looking for?

SecurityWeekSecurityWeek

Application Security

Serious Flaws Found in Moodle Learning Platform

Researchers have discovered serious vulnerabilities in Moodle, a popular open-source learning platform used by many top universities in the United States, the United Kingdom and other countries around the world.

Researchers have discovered serious vulnerabilities in Moodle, a popular open-source learning platform used by many top universities in the United States, the United Kingdom and other countries around the world.

Moodle updates released last week address a total of four vulnerabilities, including two that have a “serious” severity/risk rating and two classified as “minor.”

One of the serious flaws, tracked as CVE-2017-2641, can be exploited by an attacker to execute arbitrary PHP code on a vulnerable Moodle server. While the security hole is tracked as a single issue, Netanel Rubin, the expert who discovered the problem, says an attack is possible due to several smaller weaknesses affecting the platform.

The flaw can be exploited by an authenticated attacker to conduct an SQL injection attack via user preferences and add a new administrator user to the system. Once the attacker has an admin account on the system, they can execute arbitrary code by uploading a new plugin or a template to the server, Rubin said.

This vulnerability affects Moodle 3.2 to 3.2.1, 3.1 to 3.1.4, 3.0 to 3.0.8, 2.7.0 to 2.7.18 and older versions, and it has been fixed with the release of versions 3.2.2, 3.1.5, 3.0.9 and 2.7.19.

Moodle developers noted that the flaw can only be exploited in Moodle versions prior to 3.2 by users with manager or admin rights. In version 3.2, the attack works with any type of user account, including teacher and student accounts.

Rubin, who recently warned that vulnerabilities in smart electricity meters expose consumers and electric utilities to cyberattacks, has published a lengthy blog post detailing his findings.

The second serious flaw patched by Moodle last week has been described as a cross-site scripting (XSS) flaw in the functionality that allows users to attach files for evidence of prior learning.

“Serving files attached to evidence of prior learning did not force download. When viewed by other users they would be opened in current moodle sessions,” Moodle wrote in its advisory.

The flaw, reported by a researcher who uses the online moniker “wez3” and tracked as CVE-2017-2645, only affects versions 3.2 to 3.2.1 and 3.1 to 3.1.4.

Jaymark Pestaño discovered a less severe XSS vulnerability in the evidence of prior learning section, and Nadav Kavalerchik identified an issue related to usernames being displayed in global search for unauthenticated users. Both issues are considered minor.

Written By

Eduard Kovacs (@EduardKovacs) is a contributing editor at SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.

Click to comment

Expert Insights

Related Content

Application Security

Cycode, a startup that provides solutions for protecting software source code, emerged from stealth mode on Tuesday with $4.6 million in seed funding.

Mobile & Wireless

Technical details published for an Arm Mali GPU flaw leading to arbitrary kernel code execution and root on Pixel 6.

Mobile & Wireless

Apple rolled out iOS 16.3 and macOS Ventura 13.2 to cover serious security vulnerabilities.

Cloud Security

VMware vRealize Log Insight vulnerability allows an unauthenticated attacker to take full control of a target system.

Mobile & Wireless

Apple’s iOS 12.5.7 update patches CVE-2022-42856, an actively exploited vulnerability, in old iPhones and iPads.

Vulnerabilities

Security researchers have observed an uptick in attacks targeting CVE-2021-35394, an RCE vulnerability in Realtek Jungle SDK.

Mobile & Wireless

Two vulnerabilities in Samsung’s Galaxy Store that could be exploited to install applications or execute JavaScript code by launching a web page.

Vulnerabilities

Several vulnerabilities have been patched in OpenText’s enterprise content management (ECM) product.