Security Experts:

Cisco Patches DoS Vulnerability in ASR Routers

Cisco has released software updates to address a high severity denial-of-service (DoS) vulnerability affecting Cisco ASR 1000 Series Aggregation Services Routers.

The security hole (CVE-2015-4291) exists due to the way the Cisco IOS XE software running on ASR 1000 routers handles the reassembly of fragmented IPv4 and IPv6 packets. According to Cisco, an unauthenticated attacker can remotely cause the Embedded Services Processor (ESP) to crash by sending a specially crafted sequence of fragmented packets to the targeted device.

The vulnerability can be exploited repeatedly in order to cause an extended DoS condition.

Cisco says only ASR 1000 Series Aggregation Services Routers running affected versions of IOS XE are vulnerable to attacks. However, the company has noted that the flaw does not impact only specific combinations of ESP and Route Processor (RP).

Cisco advises customers to install the software updates to prevent any incidents. The company says it’s not aware of any attacks exploiting the vulnerability, which its own employees discovered. There are no workarounds for the flaw.

An alert published by Cisco on Wednesday provides additional details on the IOS XE security hole (CVE-2015-4293).

“The vulnerability is due to an error message that is triggered to the console and the syslog when a fragmented packet cannot be properly reassembled. When an affected device fails to successfully perform reassembly, instead of silently dropping the fragments, the ATTN-3-SYNC_TIMEOUT error message may be triggered,” Cisco said.

“On a device that is highly loaded, this condition may be leveraged to consume CPU resources that may be required by another process, resulting in a temporary halt of the queued process. In some situations this may lead to a drop of transit traffic. An attacker could trigger this vulnerability by sending a series of IPv4 or IPv6 fragments, that are designed to trigger the error message, directly to the affected device,” Cisco added.

IOS XE software versions 3.13S and prior have been confirmed vulnerable, but the company believes later versions might be impacted as well.

view counter
Eduard Kovacs is an international correspondent for SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.