Vulnerabilities

Unauthenticated RCE Flaws Could Expose 200,000+ WordPress Sites to Takeover

Vulnerabilities in The Events Calendar can provide attackers with remote code execution capabilities.

WordPress vulnerability exploited

More than 200,000 WordPress websites are potentially exposed to takeover attacks via two critical-severity vulnerabilities in The Events Calendar plugin.

A highly popular plugin with over 600,000 active installations, The Events Calendar allows administrators to easily create and manage an events calendar on their websites.

All plugin versions before 6.17.3.1 are affected by two code injection bugs that could lead to remote code execution (RCE), allowing attackers to take over sites, WordPress security firm Defiant explains.

The first security defect, tracked as CVE-2026-78159 (CVSS score of 9.8), is described as an unauthenticated code injection caused by insufficient validation.

Under certain conditions, an attacker can inject a plain-array payload that bypasses checks and executes during the processing of single-event HTML, including the comment area.

StellarWP, The Events Calendar’s developer, patched the flaw on August 25 in version 6.17.3.1 of the plugin.

Advertisement. Scroll to continue reading.

Tracked as CVE-2026-78006 (CVSS score of 9.8), the second vulnerability is described as an unauthenticated PHP object injection issue that can be exploited if comments on events are enabled and visible.

The security defect exists because insufficient protections in a plugin function can be bypassed by a commenter without authentication or approval, because the injected code is delivered to the vulnerable function before moderation occurs.

StellarWP resolved the second flaw in The Events Calendar version 6.17.4.1, which was released on September 10.

While the two security weaknesses are independent exploitation chains, both lead to RCE and the complete compromise of the WordPress installation, Defiant says.

WordPress data shows that approximately 240,000 websites use The Events Calendar versions prior to 6.17, meaning that they are affected by both vulnerabilities.

Between September 10 and 14, the plugin was downloaded just over 300,000 times, which suggests that roughly half of its installations may still be affected by CVE-2026-78006.

It is unclear how many WordPress sites are vulnerable, as the exploitation of both critical defects requires that comments are enabled in the plugin.

Related: Acronis Patches Exploited Vulnerability in cPanel Backup Plugin

Related: Enterprises Warned of Attacks Exploiting WSO2 Vulnerability

Related: Apple Patches 200 Vulnerabilities With New iOS 27, macOS Golden Gate 27 Releases

Related: $1 Million Sandbox Challenge Uncovers Linux Kernel Flaws

Related Content

Malware & Threats

Over 22.6 million exposed instances are potentially affected by the critical PHP flaws that have been targeted for over a week.

Vulnerabilities

Threat actors are attempting to exploit a high-severity unauthenticated race condition leading to remote code execution.

Vulnerabilities

An integer overflow tracked as CVE-2026-111585 could be used to execute arbitrary code on the viewer’s system.

Vulnerabilities

The flaws could lead to arbitrary code execution, authorization bypasses, and privilege escalation.

Vulnerabilities

An exploited flaw in the Remote Access SSL VPN service lets unauthenticated attackers remotely force ASA and FTD firewalls to reload.

Vulnerabilities

CVE-2026-41709 allows attackers with administrative privileges to perform operations without being logged.

Vulnerabilities

The Chrome 156 update fixes 52 bugs, while Firefox 159 was rolled out with 167 security patches.

Data Protection

FoxIO disclosed three GoAhead TLS bugs that can let revoked certificates through or expose some encrypted sessions to eavesdroppers.

Copyright © 2026 SecurityWeek ®, a Wired Business Media Publication. All Rights Reserved.

Exit mobile version