Security Experts:

Wireless Routers Plagued by Unpatched Flaws

Vulnerable routers

Wireless SOHO routers from ZyXEL, Belkin, ReadyNet, Amped Wireless, Buffalo and Netgear are plagued by multiple unpatched vulnerabilities, researchers have warned.

Vulnerabilities in Belkin Routers

Security researcher John Garrett of Ethical Reporting informed SecurityWeek that he has identified multiple vulnerabilities in Belkin AC-1750, AC-1200, N-600 and N-150 routers.

The expert reported finding various flaws in each model, including path traversals that can be used to access potentially sensitive APIs, weaknesses that allow unauthenticated attackers to alter the settings of a device, authentication bypass, and remote code execution vulnerabilities.

Garrett has published videos showing how the vulnerabilities can be exploited against routers running the latest version of the firmware available from Belkin. He also pointed out that Belkin and Belkin-owned Linksys routers have a firmware update feature that introduces a backdoor on the devices. Belkin told the expert that it’s working on patches for the reported issues.

Earlier this month, India-based security researcher Rahul Pratap Singh reported uncovering several vulnerabilities that can be exploited to compromise Belkin routers. The vendor said it was working on releasing firmware updates to patch the flaws found by Singh.

Vulnerabilities in Netgear Routers

Joel Land of the CERT Coordination Center (CERT/CC) at Carnegie Mellon University published a series of advisories last week detailing unpatched vulnerabilities in various wireless routers.

Land discovered in October that Netgear G54/N150 (WNR1000) wireless routers running firmware version 1.0.2.68 and possibly earlier are plagued by a vulnerability (CVE-2015-8263) that can be exploited to spoof DNS responses and cause clients to contact attacker-controlled hosts.

“The Netgear G54/N150 Wireless Router WNR1000v3 uses static source ports for all DNS queries originating from the local area network (LAN). An attacker with the ability to spoof DNS responses can cause WNR1000v3 LAN clients to contact incorrect or malicious hosts under the attacker's control,” CERT/CC said in its advisory.

Vulnerabilities in ZyXEL Routers

A different CERT/CC advisory details two vulnerabilities affecting ZyXEL NBG-418N routers running firmware version 1.00(AADZ.3)C0. The issues were reported to the vendor in October.

Land identified default credentials, namely admin:1234, that can be used to access the device’s web-based admin interface (CVE-2015-7283). The flaw allows a local attacker to gain privileged access to the device.

The flaw can also be used in combination with a cross-site request forgery (CSRF) vulnerability found by the researcher in the same ZyXEL router (CVE-2015-7284). The CSRF bug can be exploited by a remote attacker to execute arbitrary code in the context of the victim’s browser session.

“An attacker can perform actions with the same permissions as a victim user, provided the victim has an active session and is induced to trigger the malicious request. Note that in combination with default credentials, an attacker can establish an active session as part of an attack and therefore would not require a victim to be logged in,” reads CERT/CC’s advisory.

Vulnerabilities in ReadyNet, Amped Wireless and Buffalo Routers

The CERT/CC researcher also reported finding default credentials (CVE-2015-7280), a CSRF flaw (CVE-2015-7281) and a DNS spoofing issue (CVE-2015-7282) in ReadyNet routers.

The expert tested his findings on a ReadyNet WRT300N-DD wireless router running firmware version 1.0.26. The vulnerabilities were reported to ReadyNet in September.

Similar default credentials (CVE-2015-7277), CSRF (CVE-2015-7278) and DNS spoofing (CVE-2015-7279) vulnerabilities were also found by Land in Amped Wireless R10000 routers with the firmware version 2.5.2.11. The flaws were reported to the vendor on July 1.

A vulnerability that can be exploited for DNS spoofing (CVE-2015-8262) has also been discovered in Buffalo AirStation Extreme N600 routers (WZR-600DHP2). The affected firmware versions are 2.09, 2.13, 2.16 and possibly others.

Availability of Patches

Garrett and CERT/CC said they are unaware of patches for the disclosed vulnerabilities. SecurityWeek has reached out to all the affected vendors and will update this article if they provide information regarding the availability of fixes.

Belkin has confirmed that it's working on patches for the vulnerabilities reported by Garrett.

*Updated with statement from Belkin

view counter
Eduard Kovacs is an international correspondent for SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.