Security Experts:

VMware Patches XSS Flaws in vRealize

VMware announced on Tuesday that it released patches for the Linux version of two vRealize products in order to address cross-site scripting (XSS) vulnerabilities.

According to an advisory published by the company, the 6.x version of VMware vRealize Automation, a cloud automation software for the delivery of IT services, is plagued by a stored XSS flaw (CVE-2015-2344) that can be exploited to compromise client workstations.

The issue, reported by Lukasz Plonka, has been patched with the release of VMware vRealize Automation 6.2.4. vRealize Automation 7.x for Linux and vRealize Automation 5.x for Windows are not affected, the company said.

Another stored XSS vulnerability (CVE-2016-2075) has been found by Alvaro Trigo Martin de Vidales of Deloitte Spain in vRealize Business, a product designed to automate the core financial processes needed to plan and optimize the cost and value of IT in an organization.

According to VMware, exploitation of this vulnerability can also lead to users’ client workstations getting compromised.

The flaw affects VMware vRealize Business Advanced and Enterprise 8.x for Linux and it has been addressed with the release of version 8.2.5. vRealize Business Advanced and Enterprise 6.x and 7.x for Linux are not affected.

This is the third security advisory published by VMware this year. In January, the company issued updates to resolve a guest privilege escalation vulnerability affecting ESXi, Fusion, Player, and Workstation, and, in February, the virtualization giant started releasing patches for a recently disclosed flaw in the glibc library.

VMware also reissued a patch for a serious vCenter vulnerability that allowed remote attackers to execute arbitrary code on affected systems. The company reissued the fix after learning that it had not properly patched the problem.

view counter