Security Experts:

Advantech Failed to Patch Serious Flaws in SCADA Product

The Zero Day Initiative (ZDI) has published advisories describing several unpatched vulnerabilities affecting Advantech’s WebAccess industrial automation SCADA/HMI product.

In mid-January, ICS-CERT published an advisory describing more than a dozen vulnerabilities identified by several researchers in Advantech WebAccess 8.0 and earlier.

Ilya Karpov, Ivan Sanchez, Andrea Micalizzi, Ariele Caltabiano, Fritz Sands, Steven Seeley, and an anonymous researcher have been credited for finding unrestricted file upload, path traversal, improper access control, cross-site scripting (XSS), SQL injection, insecure storage of information, and memory corruption vulnerabilities. The vendor released WebAccess 8.1 to address the flaws and Sanchez confirmed that the issues he reported were addressed properly.

However, advisories marked “0day” by ZDI show that some of the flaws haven’t been patched properly in WebAccess 8.1.

One of them is a medium severity local privilege escalation bug reported by Sands. While ICS-CERT’s advisory contains only limited details on each flaw, the improperly patched vulnerability could be CVE-2016-0852, described as an improper access control issue.

It also appears that a couple of high severity stack-based and heap-based buffer overflow vulnerabilities reported by an anonymous researcher, CVE-2016-0856 and CVE-2016-0857, were also not patched properly by Advantech. The vulnerabilities can be exploited by a remote, unauthenticated attacker to execute arbitrary code on the targeted system, ZDI said.

ZDI has published tens of advisories describing what appear to be different variants of these vulnerabilities, which haven’t been patched with the release of Advantech’s update.

ZDI said it disclosed the flaws despite not being fixed based on its “policy on lack of vendor response.”

Advantech has not responded to SecurityWeek’s request for comment by the time of publication.

It’s not uncommon for Advantech’s patches to fail to resolve and even introduce vulnerabilities. While analyzing one of the company’s firmware updates last year, Rapid7 researchers discovered the existence of several known vulnerabilities, including ShellShock and Heartbleed. Rapid7 discovered in January that changes made in the firmware version designed to address these issues introduced another serious authentication bypass vulnerability.

view counter