Security Experts:

Vulnerability Allows Hackers to Take Control of Drupal 8 Websites

Drupal developers on Wednesday informed users that version 8.7.4 is affected by a potentially serious vulnerability, and advised them to update to version 8.7.5, which addresses the issue.

The vulnerability, tracked as CVE-2019-6342, has been assigned a “critical” severity rating. Since Drupal developers use NIST’s Common Misuse Scoring System to determine the risk level, “critical” is actually second on the severity scale, after “highly critical.”

The flaw, described as an access bypass issue that can be triggered when the experimental Workspaces module is enabled, can be exploited to take control of a targeted website.

The vulnerability was reported to Drupal developers by Dave Botsch and there is no evidence of exploitation for malicious purposes. However, this security hole could be a tempting target for hackers as it affects default/common configurations, no authentication is required, and exploitation requires minimal user interaction.

The flaw only affects Drupal 8.7.4 — Drupal 8.7.3 and earlier, 8.6.x and earlier, and 7.x are not impacted. Users who cannot update to version 8.7.5 to patch the vulnerability can prevent potential attacks by disabling the Workspaces module.

“For sites with the Workspaces module enabled, update.php needs to run to ensure a required cache clear. If there is a reverse proxy cache or content delivery network (e.g. Varnish, CloudFlare) it is also advisable to clear these as well,” Drupal said in its advisory.

The U.S. Department of Homeland Security (DHS) has also advised users to read the Drupal advisory and take the necessary measures.

It’s not uncommon for Drupal vulnerabilities to be exploited in the wild. Earlier this year, attackers started exploiting the flaw tracked as CVE-2019-6340 to deliver cryptocurrency miners and other payloads just a few days after a patch was released.

Cybercriminals also hacked many Drupal sites last year by exploiting two flaws dubbed Drupalgeddon2 and Drupalgeddon3. The attackers used the vulnerabilities to deliver RATs, cryptocurrency miners and tech support scams. Some attacks chained Drupalgeddon 2 with the DirtyCOW Linux kernel bug.

Related: Symfony, jQuery Vulnerabilities Patched in Drupal

Related: Two Code Execution Flaws Patched in Drupal

Related: Critical Drupal Vulnerability Allows Remote Code Execution

Related: Phar Vulnerabilities Patched in Drupal, TYPO3

view counter
Eduard Kovacs (@EduardKovacs) is a contributing editor at SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.