Security Experts:

Vulnerabilities in WibuKey Could Lead to Code Execution

Vulnerabilities in the WibuKey Digital Rights Management (DRM) solution could be leveraged to disclose information, elevate privileges, or even execute code on affected systems. 

Available for many interfaces and operating systems, WibuKey has been used in numerous solutions, including Straton, Archicad, GRAPHISOFT, V-Ray and others. However, Wibu Systems recommends that new projects use another of its technologies instead. 

As Cisco’s security researchers pointed out in a blog post that has since been removed, over 3,000 companies worldwide have been using the WibuKey solution to protect intellectual property and other digital content. 

A total of three vulnerabilities were discovered in the DRM solution, leading to the unauthorized reading of kernel memory information, privilege escalation on the local system, and potential execution of code on accessible WibuKey network servers.

The most important of the three vulnerabilities is an exploitable heap overflow in the WkbProgramLow function of WibuKey Network server management, tracked as CVE-2018-3991. The bug can be triggered using a specially crafted TCP package, and could lead to remote kernel level code execution, Cisco says.

Tracked as CVE-2018-3989, the second vulnerability was found in the 0x8200E804 IOCTL handler functionality of WIBU-SYSTEMS WibuKey.sys version 6.40 (Build 2400). 

“A specially crafted IRP request can cause the driver to return uninitialized memory, resulting in kernel memory disclosure,” Cisco Talos explains. 

The third security flaw, CVE-2018-3990, is a pool corruption vulnerability in the 0x8200E804 IOCTL handler functionality of WibuKey.sys. An attacker could use a specially crafted IRP request to cause a buffer overflow, which could lead to kernel memory corruption.

The vulnerabilities were found in WIBU-SYSTEMS WibuKey Network server management 6.40.2402.500 and have been addressed this week, with the release of WibuKey 6.50, available on the vendor’s website (the update arrives two years after WibuKey 6.40 was made available).

Related: Cisco Warns of Zero-Day Vulnerability in Security Appliances

Related: Cisco Patches Privilege Escalation Vulnerability in Adaptive Security Appliance

view counter