Security Experts:

VMware Fixes Several Vulnerabilities in vSphere Platform

VMware has released software updates to address a series of vulnerabilities affecting the company's popular vSphere virtualization platform.

The list of security bugs includes a cross-site scripting (XSS) flaw, a certificate validation issue, and various vulnerabilities affecting third-party libraries. The impacted products are VMware vCenter Server Appliance 5.1 prior to Update 3, VMware vCenter Server 5.5 prior to Update 2, VMware vCenter Server 5.1 prior to Update 3, VMware vCenter Server 5.0 prior to Update 3c, and VMware ESXi 5.1 without the ESXi510-201412101-SG patch, VMware revealed in an advisory published on Thursday.

VMware Vulnerabilities FixedThe XSS vulnerability (CVE-2014-3797) was discovered and reported by Tanya Secker of Trustwave SpiderLabs. The security hole affects the vCenter Server Appliance (vCSA) and it can be exploited if the attacker can trick the victim into clicking on a maliciously crafted link while logged in to the application.

The Google Security Team informed VMware of a certificate validation issue (CVE-2014-8371) affecting vCenter Server. 

"vCenter Server does not properly validate the presented certificate when establishing a connection to a CIM Server residing on an ESXi host. This may allow for a Man-in-the-middle attack against the CIM service," VMware said in its advisory.

The libxml2 (parsing XML documents), Curl (transferring data with URL syntax), and Python packages used in VMware ESXi have been updated to address multiple security issues. These bugs have been assigned the following CVE identifiers: CVE-2013-2877, CVE-2014-0191, CVE-2014-0015, CVE-2014-0138, CVE-2013-1752 and CVE-2013-4238.

VMware vCenter Server 5.1 Update 3 also addresses Oracle's Java SE vulnerabilities affecting vCenter Server and vCenter Update Manager 5.1. The company has released patches for many of the vulnerable products, but in some cases the patch is still pending.

VMware advises customers to apply the updates as soon as possible, though many organizations often fail to update their installations even when highly critical vulnerabilities are involved.

Older versions of VMware products are affected by the OpenSSL bug dubbed Heartbleed. The company started releasing patches for Heartbleed in April, shortly after the existence of the vulnerability came to light. However, virtualization management firm CloudPhysics reported in late July that many organizations had still not secured their installations. 

In late September, VMware started releasing updates for several of its solutions to address the GNU Bash vulnerability known as ShellShock.

view counter
Eduard Kovacs (@EduardKovacs) is a contributing editor at SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.