Security Experts:

Threat Actors Quick to Target (Patched) SAP Vulnerabilities

Threat actors are constantly targeting new vulnerabilities in SAP applications within days after the availability of security patches, according to a joint report issued by SAP and Onapsis.

In some cases, exploitation attempts were observed shortly after the security bugs are made public: scanning for vulnerable systems started 48 hours after patches were released, with actual exploitation attempts following roughly 24 hours later, an analysis that SAP and Onapsis conducted since mid-2020 has revealed.

Used within more than 400,000 organizations (including 1,000 government and government-owned organizations) for resource planning, management of product lifecycle, human capital, and supply chain, and for various other purposes, SAP’s applications represent an attractive target for adversaries.

During their study, the two organizations observed as many as 300 successful exploitations of SAP-specific vulnerabilities. The attacks were aimed at modifying configurations and user accounts, to ultimately access and exfiltrate business information.


“New unprotected SAP applications provisioned in cloud (IaaS) environments were discovered and attacked in less than three hours, stressing the need to “shift left” and ensure new mission-critical applications are provisioned securely from day one,” according to the report.


Sophisticated threat actors, the two organizations say, are leveraging various attack vectors to compromise organizations through unprotected SAP applications, including chaining together multiple vulnerabilities specific to SAP deployments.


The study also reveals that threat actors are making numerous brute-force attempts targeting high-privilege SAP user accounts, showing once again that maintaining secure system configurations is as important as keeping software patched at all times.


Exploited vulnerabilities include CVE-2020-6287 (also known as RECON, this critical bug has a CVSS score of 10), CVE-2020-6207 (also CVSS score of 10), CVE-2018-2380, CVE-2016-9563, CVE-2016-3976, and CVE-2010-5326. Successful exploitation of unpatched SAP bugs could lead to theft of sensitive data, financial fraud, the disruption of mission-critical business processes, and ransomware attacks, and could even force organizations to completely suspend operations.


Despite known targeting of vulnerable SAP systems, however, some organizations fail to apply the available patches in due time. Thus, together with the U.S. Department of Homeland Security (DHS) Cybersecurity and Infrastructure Security Agency (CISA) and Germany’s Federal Cybersecurity Authority (BSI), SAP and Onapsis are advising organizations to immediately apply available patches.


“SAP systems running outdated or misconfigured software are exposed to increased risks of malicious attacks. SAP applications help organizations manage critical business processes—such as enterprise resource planning, product lifecycle management, customer relationship management, and supply chain management,” CISA notes.


Organizations using SAP software are advised to perform compromise assessment on those applications, especially for Internet-facing resources, assess all applications in the SAP environment, perform misconfiguration assessments, and immediately apply all of the available patches where necessary.


Related: Scanning Activity Detected for Critical SAP SolMan Flaw

view counter