Security Experts:

Palo Alto Networks Fixes PAN-OS Vulnerabilities

Palo Alto Networks has released updates for PAN-OS, the operating system of its enterprise security platform, to address several vulnerabilities, including ones rated “critical” and “high” severity.

Advisories published by the company on Wednesday show that the most serious of the issues is a critical buffer overflow in the GlobalProtect portal. The vulnerability, caused by the improper handling of a buffer in the processing of SSL VPN requests, can be exploited to cause a denial-of-service (DoS) condition and crash a device, and possibly even for remote code execution.

The network and enterprise security company also informed users of a high severity vulnerability that allows a remote, unauthenticated attacker with access to the device management web interface to execute arbitrary OS commands.

“Palo Alto Networks PAN-OS implements an API to enable programmatic device configuration and administration of the device. An issue was identified where the management API incorrectly parses input to a specific API call, leading to execution of arbitrary OS commands without authentication via the management interface,” the company said in an advisory.

Another issue related to the GlobalProtect portal is a medium severity flaw that can be exploited by an unauthenticated attacker with network access to remotely cause the portal to crash.

Palo Alto Networks also published an advisory to briefly describe a low severity issue that allows an authenticated attacker with administrator rights to execute commands on the OS level with root privileges.

The critical and high severity vulnerabilities affect PAN-OS versions 5.0.17, 6.0.12, 6.1.9, 7.0.4 and prior, and they have been patched with the release of PAN-OS 5.0.18, 6.0.13, 6.1.10 and 7.0.5. The medium severity flaw impacts releases 5.0.17, 6.0.12, 6.1.9, 7.0.5 and prior, and it’s resolved in PAN-OS 5.0.18, 6.0.13, 6.1.10, 7.0.5H2 and newer. The low severity issue plagues versions 5.0.17, 5.1.10, 6.0.12, 6.1.9, 7.0.5 and prior, and it has been fixed in 5.0.18, 5.1.11, 6.0.13, 6.1.10 and 7.0.5H2 and newer.

According to the SANS Institute, Palo Alto Networks customers must patch their systems until March 16, when the details of these weaknesses will be disclosed at a conference.

Since the vulnerabilities were reported by Felix Wilhelm
 of German security firm ERNW Research, their details will most likely be disclosed during the researcher’s presentation on attacking next-generation firewalls at the company’s TROOPER16 conference, which is scheduled to take place on March 14-18 in the city of Heidelberg in Germany.

view counter
Eduard Kovacs (@EduardKovacs) is a contributing editor at SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.