Security Experts:

OpenSSL Vulnerability Can Be Exploited to Change Application Data

High severity vulnerability patched in OpenSSL

The OpenSSL Project on Tuesday announced the availability of OpenSSL 1.1.1l, which patches a high-severity vulnerability that could allow an attacker to change an application’s behavior or cause the app to crash.

The flaw, tracked as CVE-2021-3711, has been described as a buffer overflow related to SM2 decryption.

“A malicious attacker who is able to present SM2 content for decryption to an application could cause attacker chosen data to overflow the buffer by up to a maximum of 62 bytes altering the contents of other data held after the buffer, possibly changing application behaviour or causing the application to crash. The location of the buffer is application dependent but is typically heap allocated,” the OpenSSL Project said in an advisory.

The OpenSSL Project’s Matt Caswell told SecurityWeek that the changes an attacker could make depend on the targeted application and the type of data it holds in the heap immediately after the overrun buffer.

“Think of any kind of data that an application might hold in memory (e.g. financials, credentials, etc), and then think what might happen if an attacker could change it,” he explained.

The security hole, reported by John Ouyang, affects previous 1.1.1 versions of OpenSSL.

OpenSSL users have also been informed about CVE-2021-3712, a medium-severity vulnerability that can be exploited for denial-of-service (DoS) attacks, and possibly for the disclosure of private memory contents, such as private keys. This issue has been fixed with the release of versions 1.1.1j and 1.0.2za.

Five other vulnerabilities affecting OpenSSL were disclosed this year, including two that have been rated high severity. In 2020, only three flaws were discovered in OpenSSL.

The open source TLS library has evolved a great deal in terms of security since the disclosure of the Heartbleed vulnerability back in 2014, with only a handful of high-severity flaws being identified in the past few years.

Related: Evolution of OpenSSL Security After Heartbleed

Related: OpenSSL 1.1.1k Patches Two High-Severity Vulnerabilities

Related: Three New Vulnerabilities Patched in OpenSSL

view counter
Eduard Kovacs (@EduardKovacs) is a contributing editor at SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.