More than 100,000 WordPress websites were potentially affected by a series of vulnerabilities recently discovered and addressed in the Popup Builder plugin.
Security researchers at WordPress security firm Defiant report that Popup Builder before version 3.64.1 is impacted by vulnerabilities that could allow attackers to inject malicious code without authentication, or leak user information and system configuration data.
The most important of the vulnerabilities is a high-severity stored cross-site scripting (XSS) bug tracked as CVE-2020-10196 and featuring a CVSS score of 8.3.
The plugin registered an AJAX hook intended to allow auto-saving of draft pop-ups, but the hook was found to be exposed to unprivileged users. Moreover, the function called by the hook did not include nonce checks or capability checks.
While such vulnerabilities are typically abused to redirect users to malvertising sites or for information theft, the issue could also be leveraged for site takeover if the infected pop-up was displayed to a logged-in administrator, Defiant says.
Another issue addressed in the plugin this week is CVE-2020-10195 (CVSS score 6.3), which could allow a low-privileged authenticated user to export a list of all newsletter subscribers and system configuration details, or even grant themselves access to features of the plugin.
The vulnerabilities were reported to the plugin’s developer on March 5, with a fully patched version of Popup Builder (version 3.64.1) released on March 11.
“While we have not detected any malicious activity targeting Popup Builder, the stored XSS vulnerability can have a serious impact on site visitors and potentially even allow site takeover,” Defiant underlines.