Security Experts:

Critical Vulnerability Patched in SAP Commerce Product

SAP has released seven new security notes on February 2021 Security Patch Day, including a Hot News note that addresses a critical flaw in SAP Commerce. It also updated six previously released notes.

Tracked as CVE-2021-21477 and featuring a CVSS score of 9.9, the critical issue could be abused for remote code execution, SAP explains in its advisory. The vulnerability impacts SAP Commerce if the rule engine extension is installed.

Meant to define and execute rules to manage decision-making scenarios, the rule engine uses a ruleContent attribute offering scripting facilities. While making modifications to ruleContent should normally be allowed for highly privileged users only, a misconfiguration shipped with SAP Commerce resulted in lower-privileged users and user groups being allowed to change ruleContents.

“This enables unauthorized users to inject malicious code into these scripts resulting in a strong negative impact on the application’s confidentiality, integrity and availability,” researchers with Onapsis, a firm that specializes in securing Oracle and SAP applications, explain.

SAP has addressed the bug by changing the default permissions for new SAP Commerce installations, but additional manual remediation steps are needed for existing installations. These steps, Onapsis says, can be used as a full workaround, provided that the latest patches can’t be installed.

Two other Hot News notes that SAP included in this month’s Security Patch Day are updates to previously released notes: one deals with the Chromium browser in Business Client, and the other with vulnerabilities initially addressed in Business Warehouse in January 2021.

Next in line are two other updated security notes, one for missing authorization checks in NetWeaver AS ABAP and S4 HANA (released in December 2020), and another for a denial of service flaw in NetWeaver AS ABAP and ABAP Platform (released in January 2021). Both have a high severity rating.

The remaining security patches, either new or updated, address medium-severity vulnerabilities in NetWeaver Master Data Management 7.1, NetWeaver Process Integration, Business Objects Business Intelligence Platform, SAPUI5, Web Dynpro ABAP Applications, UI5 HTTP Handler, and HANA Database.

Related: SAP Patches Serious Code Injection, DoS Vulnerabilities

Related: SAP Releases Four 'Hot News' Notes on December 2020 Patch Day

Related: SAP Patches Several Critical Vulnerabilities With November 2020 Security Updates

view counter