Security Experts:

Critical Drupal Vulnerability Allows Remote Code Execution

Security updates released on Wednesday for the Drupal content management system (CMS) patch a “highly critical” vulnerability that can be exploited for remote code execution.

The security hole, tracked as CVE-2019-6340, is caused by the lack of proper data sanitization in some field types, which, in some cases, can allow an attacker to execute arbitrary PHP code, Drupal developers said. The issue was discovered by Samuel Mortenson of the Drupal Security Team.

Exploitation of CVE-2019-6340 is possible if the core RESTful Web Services module is enabled and it allows PATCH or POST requests. Exploitation is also possible if another web services module is enabled, such as JSON:API in Drupal 8 or RESTful Web Services or Services in Drupal 7.

Drupal 8.6.10 and 8.5.11 should address the vulnerability. Drupal 7 does not need to be updated, but there are some updates for Drupal 7 contributed modules that users have been advised to install.

“To immediately mitigate the vulnerability, you can disable all web services modules, or configure your web server(s) to not allow PUT/PATCH/POST requests to web services resources,” Drupal said in its advisory. “Note that web services resources may be available on multiple paths depending on the configuration of your server(s). For Drupal 7, resources are for example typically available via paths (clean URLs) and via arguments to the ‘q’ query argument. For Drupal 8, paths may still function when prefixed with index.php/.”

It’s important that users install the updates as soon as possible considering that it’s not uncommon for highly critical Drupal vulnerabilities to be exploited in the wild shortly after patches are released.

Last year, cybercriminals hacked a significant number of Drupal websites by exploiting two vulnerabilities dubbed Drupalgeddon2 and Drupalgeddon3. The attackers leveraged the flaws to deliver RATs, cryptocurrency miners and tech support scams.

Other recent attacks involved exploits that chained Drupalgeddon 2 with a Linux kernel vulnerability known as DirtyCOW.

Related: Two Code Execution Flaws Patched in Drupal

Related: Drupal Refutes Reports of 115,000 Sites Still Affected by Drupalgeddon2

Related: Remote Code Execution Flaws Patched in Drupal

view counter
Eduard Kovacs (@EduardKovacs) is a contributing editor at SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.