Security Experts:

Cisco Patches Serious Vulnerabilities in Data Center Products

Cisco this week announced the release of patches for a critical vulnerability affecting its Application Policy Infrastructure Controller (APIC) and Cloud APIC products.

Tracked as CVE-2021-1577 (CVSS score of 9.1), the issue exists because of improper access control. An unauthenticated, remote attacker could exploit the vulnerability to upload files to an affected device, gaining the ability to read or write arbitrary files.

There are no workarounds to address the vulnerability. However, the company did release patches for versions 3.2, 4.2, and 5.1 of Cisco APIC and Cloud APIC, encouraging customers to apply them as soon as possible, or to migrate to a patched release.

Cisco also released patches for two high-severity bugs in APIC and Cloud APIC, both of which could be exploited to escalate privileges on an affected system.

Three medium-severity issues -- a stored cross-site scripting, a command injection and a file upload issue -- were also addressed in APIC and Cloud APIC.

APIC is one of the main components of Cisco’s Application Centric Infrastructure (ACI) software-defined networking solution for data centers.

Additionally, the company patched two high-severity vulnerabilities in NX-OS software, and two in Nexus 9000 series fabric switches, all leading to denial of service (DoS). Various other medium-severity flaws were also patched this week.

None of these vulnerabilities appears to be exploited in the wild, Cisco says. Information on all bugs is available on Cisco’s security portal.

In an update to an advisory published last week, Cisco reveals that it has concluded its investigation into whether its devices are impacted by the BadAlloc flaw that BlackBerry confirmed last week to affect specific QNX releases.

“Cisco has completed its investigation into its product line to determine which products may be affected by this vulnerability. No products are known to be affected,” Cisco says.

Related: Cisco: Critical Flaw in Older SMB Routers Will Remain Unpatched

Related: Code Execution Flaw Found in Cisco Firepower Device Manager On-Box Software

Related: Cisco Patches High Severity Vulnerabilities in BPA, WSA

view counter