Security Experts:

Google Issues Emergency Patch For Critical Android Rooting Exploit

Google has released an emergency security patch to address a local elevation of privilege vulnerability in the Android kernel that affects certain devices.

Deemed critical, the vulnerability (CVE-2015-1805) can be exploited by rooting applications to gain elevated privileges and run arbitrary code, which could lead to local permanent device compromise. According to Google, the issue affects all Android devices on kernel versions 3.4, 3.10 and 3.14, including all Nexus devices, but devices using Linux kernel version 3.18 or higher are not vulnerable.

CVE-2015-1805 Puts Android Devices at RiskThe elevation of privilege vulnerability in the Android kernel was found to allow local malicious applications to execute arbitrary code in the kernel. Thus, the affected device could be permanently compromised and possibly requiring a re-flash of the operating system to be repaired, the company’s advisory reveals.

The vulnerability can be exploited by rooting applications that users have installed on their devices, and Google is already aware of such apps being available. However, the company notes that it has blocked the installation of software that abuses the flow, both within Google Play and outside of Google Play, through Verify Apps.

Google’s advisory reveals that the issue was discovered in the upstream Linux kernel and was resolved in April 2014, but it wasn’t deemed a security flaw until last month. On Feb. 19, Google was informed by the C0RE Team that vulnerability is exploitable on Android.

Last week, security firm Zimperium, which in 2015 discovered the Stagefright flaw in Android, warned Google that the flaw was being abused on a Nexus 5 device. According to Google, it has confirmed that a publicly available rooting application abuses the vulnerability on Nexus 5 and Nexus 6 to provide users with root privileges.

When discovered last year, the Stagefright vulnerability affected Android mediaserver and was said to impact over 950 million device. Flaws in mediaserver continue to exist as the company resolved Stagefright 2.0 flaws in October and patched other Critical issues in the component this month.

A fix for the newly discovered elevation of privilege vulnerability was released in the AOSP repository for multiple kernel versions. Furthermore, the security update should be arriving on Nexus devices soon, and Google says that it notified its partners on these the fix last week, and that it would inform them when the patch is available for devices.

While the issue has been confirmed on Nexus 5 and 6, all unpatched versions of Android contain the vulnerability, Google said. To stay protected, users should have on their Android devices a security patch level of March 18, 2016, or a security patch level of April 2, 2016 and later.

view counter